Raspberry Pi Power Supply Checker

Mon problème

Bonsoir à tous,

Suite à une bascule de mon disque de donnée (micro SD vers disque dur externe HDD) j’ai des problèmes qui sont apparus :

  • RPI Power Status est constamment à l’état : « Problème ». Dois-je conclure que mon alimentation n’est plus suffisante pour alimenter RPI + Dongle + disque dur externe HDD ?

  • Mon dongle Z-WAVE n’est plus capable d’inclure mes capteurs zwave. C’est comme si ils ne les voyaient pas du tout. J’ai des timeout à chaque tentative d’inclusion pourtant sa LED clignote lors des tentatives… Et ils marchaient très bien avant le passage sur disque dur externe HDD…

Des suggestions pour réparer ces « soucis » qui sont peut être liés ?

Le tutoriel d’origine

Pour le transfert de mon disque de donnée, j’ai suivi ce tuto :

Ma configuration


[center]## System Health

version core-2022.3.4
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.9.9
os_name Linux
os_version 5.10.92-v8
arch aarch64
timezone Europe/Paris
Home Assistant Community Store
GitHub API ok
Github API Calls Remaining 5000
Installed Version 1.11.3
Stage startup
Available Repositories 1
Installed Repositories 1
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 7.5
update_channel stable
supervisor_version supervisor-2022.03.3
docker_version 20.10.9
disk_total 916.2 GB
disk_used 2.8 GB
healthy true
supported true
board rpi4-64
supervisor_api ok
version_api ok
installed_addons Terminal & SSH (9.3.0), Samba share (9.5.1), Mosquitto broker (6.0.1), File editor (5.3.3), Duck DNS (1.14.0), Z-Wave JS to MQTT (0.36.0)
Lovelace
dashboards 1
resources 0
mode auto-gen
[/center]

Ca sens l’alimentation faible, ton hdd est alimenté par le rpi en usb ou a une allimentation externe ?
Quel puissance ton alimentation?

j’avais installer retropie avec un ventilateur 5v brancher sur le gpio, un dongle usb pour un clavier souris, une manette ps4, un stick d’arcade et une dolphin bar. J’ai une alimentation en 3A et ca fonctionnais bien, par contre avec l’alimentation officiel en 2.5A j’avais des problème d’alimentation.

Salut,

Quand tu dis HDD, c’est vraiment un disque dur mécanique?
Si c’est le ca et s’il n’est pas alimenté par autre chose que le port usb du RPi il est probable que ce soit ton soucis.
Le soucis Zigbee peut être lié aussi, surtout si tout est branché sur les ports USB3.

Quelle est la puissance que peut délivrer ton alimentation?
Une alim 2.5A peut donner au max 12,5W
Un RPi4 va en consommer ~4W en idle et jusqu’à 6-7W en charge.
Un HDD c’est 2-4w quand il tourne, jusque 10w suivant le modèle en charge.
Donc c’est vite saturé.

Petit lien sur les RPi4 et la puissance des ports USB:
https://support.thepihut.com/hc/en-us/articles/360015272218-How-much-current-can-I-draw-from-a-Raspberry-Pi-USB-port-#:~:text=If%20you’re%20adding%20USB,ports%20at%20the%20same%20time.

Hello,
Merci pour ta réponse !

Il est alimenté en USB par mon RPI

En sortie de mon alimentation j’ai 5V et 3A.

Ça me fait tilter que moi aussi j’ai un ventilateur 5V sur mon RPI !
Je pense aussi que l’alimentation n’est pas suffisante… Que faire ? Passer une alimentation plus puissante ?

En complément : à l’arrière de mon disque dur HDD il est mentionné : 5V et 0.85 A.

Est-ce que démon toi l’alimentation 5V 3A suffit pour le RPI, Le disque dur HDD, le ventilateur 5V ?

moi j’ai pas de hdd, mais j’opterais pour un hdd externe en usb alimenter par une source externe que par l’usb du rpi. Et normalement avec un ventilateur 5v et ta clef zwave sa devrais être bon.

Je ne sais pas… Voici une photo de l’étiquette du disque dur à l’arrière :

Seul le disque dur externe est branché sur port USB 3.0 mais peut être que ça suffit à faire planter le dongle…

P = 5v x 3A = 15W max a priori

Selon les données inscris à l’arrière du disque :
P= 5V x 0.85A = 4.25W

Donc 7W le RPI en charge + 4,25W le HDD selon la doc constructeur ça ferait 11,25W. Sans compter le dongle et le ventilateur…

Donc selon toi faut que je prenne une alim qui délivre plus de courant/voltage ?

Bien vu ! Mon boîtier a qu’une sortie type C et il a été livré avec un câble type C vers USB 3.0. Donc à priori je ne pourrai pas l’alimenter par autres choses de que L’USB…

Je crois qu’il va falloir changer de boîtier du coup

avec une alimentation secteur qui a un port usb , ca devrait aller.

1 « J'aime »

Soit ça, soit par un hub USB alimenté, mais bon ce n’est pas forcément idéal non plus.
Bon pour être plus direct, je dirais tu aurais plus de chances avec un SSD en fait…
19€ à 25€ pour un SATA 128Go en ce moment.

Pourquoi j’aurai plus de chance avec un SSD ? Car cela consomme moins d’énergie qu’un HHD ? Le SSD ne m’arrange pas car je voudrai disposer d’au moins 1TB de stockage pour faire du stockage de média… Je vous laisse imaginer le prix. Et comme j’ai déjà le HDD d’1TB je vais tenter le hub USB alimenté, sur quelques forums j’ai vu que ça marchait bien ! Je viens de commander ce modèle :

Cdiscount

En espérant que ça resolve mon soucis !

Oui je disais ça pour la conso.
C’est sûr que si tu veux du stokage plus conséquent c’est pas donné :slight_smile:

1 « J'aime »