OpenMQTTGateway

bonjour,

j’essaye de mettre en place une passerelle openMQTTgateway depuis une semaine mais je n’y arrive pas et je compreds pas pourquoi, je vais devenir dingue

j’ai tenté avec ESP8266, ESP32
des recepteurs RXB6, MX-RM-5V et j’ai meme commandé un CC1101

j’utilise la page web install (Option 1) Upload from the web | OpenMQTTGateway v0.9.13
je connecte bien mon récepteur sur la pate D3 du ESP8266 ou 27 du ESP32 avec du 5V au cul sur les emetteurs

MQTT explorer voit bien la passerelle et lui remonte bien son uptime mais c’est tout

merci de votre aide

Salut,

Je ne vais pas pouvoir t’aider directement, car je ne connais pas OpenMQTTGateway, je ne sais pas s’il y a beaucoup d’utilisateurs sur ce forum, vu que c’est pas exactement HA.

En revanche dans ce que tu expliques, tu dis juste que tu n’arrives pas à voir les infos de tes capteurs sur le broker MQTT, mais ils manque un peu d’infos sur les tests de communication RF.
Si j’ai bien compris openMQTTgateway c’est juste un firmware ou un programme qui publie sur MQTT ce que les capteurs reçoivent.
Mais as tu des moyens de voir si tes modules RF marchent bien?
Y’a t’il moyen de voir un log? Par exemple en regardant ce que sort la console de Arduino? Ou alors le firmware at’il une interface web?

Salut.
J’ai une paire d’esp32 qui marchent très bien :

  • sélection de la bonne carte esp et de la bonne version (ble chez moi) precompilée
  • Flash directement depuis site officiel via usb
  • Connection au point d’accès de l’esp
  • paramétrage wifi et mqtt
  • Reboot de l’esp32

Voilà c’est fait et c’est fonctionnel.
Le premier point est super important. Il y a plusieurs combo possibles donc si tu prends le mauvais (un truc sans bf si on reste dans mon cas) il y a toutes les chances que ton appareil ne voit rien autour. Le second me semble bien plus simple que ta méthode

Salut,

Quel est ton modèle d’appareil émetteur RF ?
Peux tu envoyer une photo de tin setup ?



voila le matériel que j’utilise (il manque juste l’alim 5V sur les photos)
pas besoin pour le montage CC1101 car il tourne en 3.3V

la tension est bien présente sur les récepteurs ( verif avec multimétre)
j’ai plusieurs émetteurs 433 MHz autour qui sont bien récupérés par mon RFlink (j’ai vérifié sur le site OMG pour la compatibilité de mes appareils)

merci de votre aide

Peux tu connecter le MX-RM-5V et partager une photo du montage avec celui la (il faut ajouter une antenne au récepteur) ?

voila le montage avec le MX-RM-5V

alimentation esp avec USB et alim du MX-RM-5V en 5V via l’alim (masse reliées ensemble)

pour l’antenne, il y a un trou sur le pin de l’antenne , je mets un simple fil

merci

Tu mets un cable de quel longueur pour l’antenne ?
De mémoire c’est 17.3cm.
Est ce que tu as un multimetre pour verifier le cablage ?

Une fois que tu es certain du hardware je te conseille d’essayer le projet ci dessous et regarder s’il detecte un signal :

1 « J'aime »

tout a fait 1/4 d’ondes
j’ai vérifier au multimetre car je pensais que ma plaque d’essai avait une coupure vu que je ne recevais rien. j’ai aussi changer mon MX-RM-5V (achat d’un lot de 10 il y a quelques années)

par compte au niveau de la programation, il fait comment pour détecter sur quel pin est le détecteur ? je branche sur le 27 pour ESP32 et D3 sur ESP8266

et j’ai utiliser les modeles :
-esp32dev-multi_receiver
-esp32dev-rtl_433

  • esp32dev-weatherstation (a la base c’est ce qui m’intéresse car j’ai une station auriol)

-nodemcuv2-weatherstation
-nodemcuv2-rf2-cc1101

  • nodemcuv2-rf2

Ce sont bien les pins par defaut des firmwares OMG.

Tu peux essayer le SimpleRcScanner en changeant le pin du sketch pour verifier ton montage.

je compile ce fichier sur mon esp SimpleRcScanner/SimpleRcScanner.ino at master · sui77/SimpleRcScanner · GitHub
?
et je modifie la ligne 8 pour le port Controle module DiO 433 MHz - Nathalie & Guilhem

Juste ca pour verifier que ton montage est bon.