Could not sync group address '1/3/2'

Mon problème

Bonjour

N’ayant pas le fichier de projet ETS, comme je l’ai expliqué dans ma présentation, j’ai retrouver les infos de mes devices via monitoring avec knxmap.

A partir de là, j’ai rempli la config de Home Assistant (version raccourcie, mais toutes les lumières suivent le même pattern) :

knx:
  tunneling:
    host: '192.168.50.47'
    local_ip: '192.168.50.200'
  light:
    - name: "Salon.Plafond"
      address: '1/0/2'
      state_address: '1/3/2'
    - name: "Salon.Mur"
      address: '1/0/3'
      state_address: '1/3/3'

Dans l’interface web, un coup les lumières sont actives/actionnables, un coup elles sont grisées, et ça change toutes les 5 ou 10 secondes

Et dans le fichier de log, j’ai des erreurs en boucle :

2021-12-05 15:49:17 WARNING (MainThread) [xknx.log] Error: KNX bus did not respond in time (2.0 secs) to GroupValueRead request for: 1/3/2
2021-12-05 15:49:17 WARNING (MainThread) [xknx.log] Could not sync group address '1/3/2' (Salon.Plafond - State)
2021-12-05 15:49:17 WARNING (MainThread) [xknx.log] Error: KNX bus did not respond in time (2.0 secs) to GroupValueRead request for: 1/3/3
2021-12-05 15:49:17 WARNING (MainThread) [xknx.log] Could not sync group address '1/3/3' (Salon.Mur - State)
2021-12-05 15:49:22 WARNING (MainThread) [xknx.log] Received DisconnectRequest from tunnelling sever.`

Merci de m’avoir lu :slightly_smiling_face:

Ma configuration


System Health

version core-2021.11.5
installation_type Home Assistant Container
dev false
hassio false
docker true
user root
virtualenv false
python_version 3.9.7
os_name Linux
os_version 4.4.59+
arch x86_64
timezone Europe/Brussels
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Lovelace
dashboards 1
resources 0
mode auto-gen
___

Je me réponds moi-même, au cas où ça en aiderait d’autres…

Enfin, c’est plutôt un début de réponse :
Apparemment, ce serait du côté de mon module KNX-IP BAOS que la connexion serait coupée régulièrement, à moins que ce ne soit un intermédiaire (le Syno/docker) ?
En tout cas, il semblerait que HA lui-même ne soit pas en cause.

J’ai essayé de lancer knxmap alors que HA tournait, et dans certains cas, il me répond « NO_MORE_CONNECTIONS », et quelques secondes plus tard, il accepte la connexion parce que celle avec HA est visiblement coupée…

Je dois avoir encore un raspberry quelque part pour voir si ça fonctionne mieux sans container…

Sinon pour récupérer les GA KNX, tu peux utiliser Node-Red avec le Node knx-ultimate…

Merci pour cette suggestion…
Je vais creuser la piste Node-Red

Étant en phase de prise en main de HA suite à l’arrêt de Lifedomus et de retour dans node-Red et le Node Knx j’ai un peu ramé en passant à la version KNXultimate très différente de la version KNX que j’utilisais précédemment
Je suis tombé les tutos de Max Supergiovane
Et du coup je te conseille d’utiliser KNX-Ultimate Wiever
Une fois installé la connexion multicast le Wiever te renvoie toutes les données qui passent sur le bus un peu comme avec le mode diagnostic d’ETS5

1 « J'aime »

Donc, tu combines HA et Node-Red pour l’accès au GA KNX ?

Est-ce que le Viewer fonctionne aussi sans import initial de CSV ETS ?
(Vu que je ne l’ai malheureusement pas :frowning: )

Je ne sais pas encore si le Wiever peut le faire
Par contre avant de découvrir KNX Ultimate d’autres node Knx plus ancien que j’ai déjà testé devrait permettre de le faire avec une requête pour faire de l’interrogation systématique et envoyer les données vers une base de données
J’ai dans l’idée de pouvoir utiliser ce type de méthode pour mettre à jour d’autres modifications futures du knxproj
As-tu au moins le fichier ETS?? Sinon les autres méthodes passent par des logiciels spécialisés trop coûteux pour une seule installation
Reste soit une méthode avec NodeRed soit la recréation de tout ton projet

Non, je n’ai malheureusement rien issu d’ETS…

L’installateur avait tout mis en place, et je lui avais demandé de me fournir ce qu’il fallait pour que je puisse « jouer » en domotique, sans savoir trop ce qu’il en était à l’époque… (il y a 7 ans)
Il m’avait répondu qu’il m’enverrait ça, mais ne l’a jamais fait, malgré plusieurs relances…

Disposes-tu d’ETS5???
As-tu réussi à te connecté à ton IP Knx??
Ça devrait se faire avec l’IP Multicast ??

Non, pas de ETS5, n’ayant rien mis installé moi-même…
Et ça me ferait mal quand même de devoir payer une licence pro (vu le nombre de « participants ») à 1000 € pour faire tourner une solution gratuite comme HA et/ou node-red :wink:
A l’époque de mon premier post, j’avais fini par poster sur le forum HA officiel et j’avais été en contact avec un des dev de xknx mais on avait pas réellement trouvé la source du problème. Depuis, j’avais un peu abandonné mais ton post m’a redonné un peu d’espoir :wink:

Avec les versions d’HA avant novembre 2021, ça fonctionnait en partie (comme expliqué ci-dessus) et à partir de cette version, ils ont changé la gestion d’erreurs, et du coup ça fonctionnait encore moins.
Par contre, quand j’avais essayé d’autres solutions comme Homey, la gestion KNX fonctionnait apparemment mieux (mais d’autres choses me plaisaient moins, forcément, sinon je ne serais pas ici :wink: )

Bref, faut que je me relance là-dedans :slight_smile:

Avec Node-red et KNX Ultimate après avoir pas mal ramé, j’obtient ceci
image
IL suffit actionner les commandes disponibles dans ton installation et tout s’affiche ensuite

Merci pour tout ça…
Ça me fait un peu peur quand tu parles d’avoir pas mal ramé, alors que je rame déjà pour avoir un node-red opérationnel :sweat_smile:

Blague à part, tu as des conseils et/ou de bons liens pour le démarrage avec node-red ?
J’ai essayé, pour commencer, avec une simple image node-red avec docker & portainer sur mon synology, mais ça se plante à chaque fois au démarrage avec des messages peu clairs.

Un lien vers des videos

Merci encore @richardpub

node-red tourne maintenant sur mon syno…
Généralement mes containers docker ont leur config dans un répertoire « monté », mais pour rode-red, j’avais à chaque fois des problèmes de droits… En essayant avec un volume géré par docker, tout semble fonctionner…

Ce soir, je teste KNX ultimate :slight_smile:

Bonjour Richard

Peux tu me communiquer ta référence de passerelle stp.
Comment as-tu procédé dans Node red. Quel noeud as-tu utilisé.
Je suis preneur de cette solution.

Peux tu me dire comment tu utilises knxmap stp avec quoi tu utilise ceci. J’ai le même problème que toi.

Je fais avec KNX Ultimate Et suis la vidéo avec le lien si dessus
Pour l’instant je suis en phase de reconstruction de tout mon HA sur Proxmox avec soit Node-Red sur HA, ou soit sur sa propre VM
Commence par une installation directement sur HA, pour commencer et avec la vision des éléments du bus KNX dans le debbugger de Node-Red

Pour knxmap, il faut au préalable installer Python, et il me semble que j’avais eu des soucis pour avoir une version compatible… (ça fait quand même quelques mois que j’avais joué avec ça :slight_smile: )

Donc, si Node-Red te parle plus et/ou si tu vas de toute façon l’utiliser par la suite, ça me semble plus simple de l’utiliser en mode « bus monitoring » comme le propose @richardpub