Caméras et NVR HIKVISION

Bonjour,

Je voudrais récupérer la visualisation de mes caméras dans Home Assistant. Y’a t’il une intégration qui le permette ? Sinon comment faire ? Faut il utiliser le NVR pour accéder aux caméras ou caméra par caméra ?
J’ai essayé avec l’intégration ONVIF mais rien ne fonctionne. Mes caméras sont en protocole HIKVISION mais je vois un paramétrage pour activer le ONVIF. Si quelqu’un a un tuto ou la procédure pour savoir comment faire.

Merci

Pour trouver l’URL d’accès direct aux streams des caméras, j’utilise cet excellent site: https://securitycamcenter.com et pour hikvision: Hikvision RTSP URL address format — SecurityCamCenter.com
Il marche pour (beaucoup) de caméras.
Pour les hikvision (en accès direct) l’URL que l’on y trouve est de la forme:

Local IP address
The local IP address of the device is: 192.168.1.100 and the RTSP port is 554. These are the RTSP streaming addresses:

Hikvision Main Stream: rtsp://admin:password@192.168.1.100:554/Streaming/Channels/101
Hikvision Sub Stream: rtsp://admin:password@192.168.1.100:554/Streaming/Channels/102

Teste avec VLC (par exemple) que l’URL marche.
Ensuite, dans HA créer une entité caméra avec Generic Camera - Home Assistant puis la carte lovelace qui va bien Picture Entity Card - Home Assistant et c’est parti.

Bonjour et merci pour ton aide. Je n’y arrive pas, je ne sais pas ce qu’il faut adapter et/ou paramétrer au niveau de mes caméras. Le channel comment tu le connais ?
J’ai un NVR avec 3 caméras dessus. J’utilise quelle adresse IP du coup ?

De plus comment testes tu dans VLC?

Ma config dans HA :

Désolé je maitrise pas

Salut Stef,

Essais comme ça pour voir :

- platform: generic
  name: Caméra entrée
  still_image_url: http://user:password@192.168.254.2:80/ISAPI/Channels/101/picture
  stream_source: rtsp://user:password@192.168.254.2:554/Streaming/102
  verify_ssl: false
  authentication: digest

Dans « média », « ouvrir un flux réseau » et tu colles une des 2 lignes, puis « lire » :

http://user:password@192.168.254.2:80/ISAPI/Channels/101/picture
rtsp://user:password@192.168.254.2:554/Streaming/102

Salut Herbs, malheureusement cela ne marche pas…
Question bête mais pour accéder à mes caméras sur un navigateur, je mets l’adresse de mon NVR avec un port 65001, 65002 pour la deuxième etc. Je ne ping pas la caméra au 192.168.254.2…y’a pas un truc à faire dans la configuration des caméras ou du NVR ?

Effectivement à partir de là c’est mal engagé :frowning:

L’ip 192.168.254.2 tu l’as trouvé comment du coup ? peux-tu préciser le modèle de nvr que tu utilises ?

C’est un NVR HIKVISION DS-7604NI-K1-4P.

Les IP sont sur mon NVR dans ce tableau situé dans « Système », « Gestion de caméra » et onglet « Caméra IP »

et si tu clics sur l’url dans la colonne « join » ça donne quoi ?

C’est l’URL (192.168.1.16:65001) qui me permet d’accéder à ma caméra 1 via un navigateur (page de login). C’est l’adresse IP du NVR sur le port 65001. C’est pour ça que je suis un peu perdu vu qu’on a un port pour le RTSP. Y’a rien à paramétrer sur la caméra ?

Ok alors si on considère que :

  • le nvr est en 192.168.1.16 y’a des chances que le reste de ton réseau local le soit aussi
  • que les caméras sont en 192.168.254.x ça voudrait dire que le nvr créé son propre subnet derrière lequel il raccroche les caméras (qui du coup ne sont pas joignable directement depuis 192.168.1.x).

Donc soit tenter de récupérer le flux directement depuis le nvr (voir pour affiner les paramètres) :

- platform: generic
  name: Caméra entrée
  still_image_url: <l'url dispo dans la colonne join>
  verify_ssl: false

Ou voir si t’as moyen de modifier l’ip de tes caméras pour les remettre dans le subnet en 192.168.1.x, mais je sais pas comment va le prendre le nvr ???

Faudrait qu’un utilisateur expérimenté de ce genre de matos passe filer un coup de main.

Je t’avoue que ne possédant pas ce matériel c’est un peu compliqué de t’aiguiller correctement.

Pour les accès aux caméras, il est fort probable que le NVR fasse proxy rstp… En tout cas, ça à l’air d’être le cas quand je vois ça

rtsp://NVR-IP-ADDRESS/Streaming/Channels/101

The 101 at the end means:

x01 - where x equals channel number
1xx - where xx equals 01 is Main Stream and 02 is Substream

Donc potentiellement pas besoin d’accéder aux caméras en direct

1 « J'aime »

j’ai essayé de lire le post en anglais mais du coup je ne comprends pas bien ce que je dois faire…si vous pouvez m’éclairer.

On your NVR network settings :

  1. Set up a static IP - this can be done easily on your router (sometimes called DHCP reservation) or by simply disabling DHCP and ensuring that the IP address, Subnet mask, Gateway, and DNS server are correct.
  2. Take note of the IPv4 Address (i.e. 192.168.1.X), IPv4 Default Gateway (i.e. 192.168.1.1) , and Internal NIC Address** (by default its 192.168.254.1)
  3. Enable Virtual-Host, you will find the option under Network Settings → Advanced (if you have it)
  4. You should now have access to your cameras through your NVR through http://192.168.1.X:6500Y where Y is the camera number. The links are also provided in the « Camera Management » page.

On your cameras:

  1. Login to the camera - the credentials will either be the same as your NVR, or admin/12345
  2. Go into the Network configuration and change the IPv4 Default Gateway to your NVR Internal NIC Address (i.e. 192.168.254.1)
  3. Save and reboot (as prompted)
  4. Your cameras should now have access to the internet (they can send email alerts, upload to FTP, etc…)

On your router (this is the tricky part):

  1. You want to set up a « Static Route » (Google is your friend) - Different routers will likely have different specific terms, so the following is for a Linksys router
  2. Set the « Destination LAN IP » to your NVR internal NIC address, but instead of the ending with a 1, it will end with a 0. So if your Internal NIC Address is 192.168.254.1, you want to set it to 192.168.254.0.
  3. Set the « Subnet Mask » to be the same as on your NVR (likely 255.255.255.0)
  4. Set the « Gateway » to your NVR IPv4 Address
  5. You should now be able to access your cameras through their internal IP addresses (i.e. 192.168.254.X)

La partie 1 ( On your NVR network settings) c’est bon car l’hôte virtuel est déjà activé.
Par contre la partie 2 ( On your cameras:) j’ai essayé mais je n’ai pas l’impression que cela est fonctionné. Et la dernière partie ( On your router) je ne sais ce qu’il faut faire

Essaye les flux à travers vlc :

Pour la camera 1:

rtsp://admin:12345@192.168.1.16:554/PSIA/Streaming/Channels/101
rtsp://admin:12345@192.168.1.16:554/Streaming/Channels/101
rtsp://admin:12345@192.168.1.16/Streaming/Channels/101
rtsp://admin:12345@192.168.1.16/PSIA/Streaming/Channels/101

rtsp://admin:12345@192.168.1.16:554/PSIA/Streaming/Channels/102
rtsp://admin:12345@192.168.1.16:554/Streaming/Channels/102
rtsp://admin:12345@192.168.1.16/Streaming/Channels/102
rtsp://admin:12345@192.168.1.16/PSIA/Streaming/Channels/102

Et puis 201/202 pour la caméra 2. 301/302 pour la caméra 3 etc…

J’ai adapté avec mon mot de passe Admin à la place du « 12345 » mais cela ne fonctionne pas

Bon ben là, à part se farcir la doc du nvr…

Je galère dès que je veux faire un truc sous HA. Pourtant j’ai une configuration assez banale avec du matos de marque…c’est chronophage.

Aurais tu compris la manip :
On your router (this is the tricky part):

  1. You want to set up a « Static Route » (Google is your friend) - Different routers will likely have different specific terms, so the following is for a Linksys router
  2. Set the « Destination LAN IP » to your NVR internal NIC address, but instead of the ending with a 1, it will end with a 0. So if your Internal NIC Address is 192.168.254.1, you want to set it to 192.168.254.0.
  3. Set the « Subnet Mask » to be the same as on your NVR (likely 255.255.255.0)
  4. Set the « Gateway » to your NVR IPv4 Address
  5. You should now be able to access your cameras through their internal IP addresses (i.e. 192.168.254.X)

Je pourrais tester de la faire vu que la première partie me parait déjà réalisée pour moi.

En tout cas merci pour ton aide

Oui, là il s’agit de faire une route réseau… On commence à rentrer dans le dur : à savoir, faire véritablement de l’administration réseau et de la gestion de VLAN… C’est pas facile facile … Et plus il faut un ‹ truc › qui fasse router, et que le réseau soit correctement raccordé
Je m’avancerai pas à te donner des indications pour faire ça : tu n’as pas l’air de connaitre (juste un constat) et moi je suis à distance, c’est un coup à rendre tout HS à la moindre fausse manip.

Commence par faire simple, la documentation c’est souvent la bonne piste. Il faut trouver la tienne (en français si pas à l’aise avec l’anglais) et la lire attentivement. Si pas de solution dedans, il sera toujours temps de bricoler les réseaux…

Euh… Galérer, OK. « sous HA » là, ça se discute. Tu as un NVR qui semble t il ne se comporte pas comme la doc que pulpy a trouvé sur internet semble l’indiquer. Donc, le « fautif » c’est plus le NVR hikvision qu’autre chose.

Par exemple le fait que le NVR semble imposer que les webcams soient dans un sous-réseau différent (et donc mette la grouille d’ou la config réseau spéciale), ce n’est pas un problème HA.

Que dit VLC? Quelle est l’erreur exacte?

1 « J'aime »

Ce que je veux dire c’est que c’est la croix et la bannière dès que je veux faire quelque chose.

Voilà ce que j’ai :

Tu as mis les 8 entrées d’un coup?
Il faudrait tester une à une. Comme aucun de nous n’a ce NVR, pulpy propose plusieurs trucs en espérant que l’un marche.

Je comprends et c’est frustrant.

Sans vouloir faire la groupie de HA, souvent, les problèmes viennent des trucs autour.
Dans le cas de ton NVR, c’est conçu comme un système fermé pour que ça marche sans trop se poser de question.
La conséquence de ce choix de hikvision, c’est dès que tu veux faire un truc qui n’est pas pile poil prévu, c’est pénible.

La grande majorité des systèmes propriétaires (les box, le wifi de google, ce NVR,…) sont conçus avec un ecosystème défini et -le plus souvent- fermé ou à peine entrouvert.

HA, c’est tout l’inverse. C’est un (très bon) couteau suisse. Et ce couteau suisse essaie de s’adapter à tous les bidules autour qui n’ont pas été conçu pour ça. Et c’est ça la galère.

Je ne crois pas qu’il existe un système aussi ouvert dont les interfaces avec des systèmes (presque) fermés marchent en trois clics.

1 « J'aime »